What's new

Ping and Connectivity Issues Since Update

Juggs

Lose without excuses
Lead Moderator
After the most recent patch dropped, I immediately noticed a difference online. It was consistently worse than it had been. And the issue still persists.

For instance, before I play someone, it will say the ping is anywhere between 30-70. Which is perfectly fine. The problem is, once the match starts, it stays above 100 ping.

There seems to be more button delay, and lag than before. And this is pretty consistent. The SAME exact players where I was getting a consistent 50 ping the entire match, is now around 100. There’s even random HUGE lag spikes somehow when both players are wired. None of this happened to me before the update.

Many others seem to be experiencing the same problem. Do any of you notice a difference? Also, what could be causing this? I know nothing about programming or anything related to what the problem could be, so if someone knows or has an idea, post it up.
 

Eldriken

You are marked for termination.
Forum General
I'm glad someone is legitimately addressing this. It's really become an issue lately. It's becoming quite unbearable at times.

Also, before anyone even thinks of doing so, let's not mention anything about other peoples' connections. That's not what this is about, so save that nonsense for another thread/status update.

I just want it to get fixed.
 

xenogorgeous

How could you tell?
Premium Supporter
yeah, this last update fucked up badly .... FPS drop randomly, crashes occurring all of sudden, and online seems to become a bit "heavy", and it's harder to execute some combos .... :confused:

the cause/source/origin of this ? probably some hurry up on doing and programing the patch, without heavily testing on QA departament ..... some people are even comenting that is consuming much more memory and CPU power in PC, what seems to be truth , so, yeah, they have to get rid with what causing these effects, just doing a patch that corrects this patch, lol ! :p
 

JBeezYBabY

Mr. Righteous
I don't play Ranked matches, I just play Casual matches so I'm unable to see the ping. HOWEVER, I am noticing my matches is getting much lag since the update w/ that yellow/red triangle appearing on the bottom of my screen way more than usual. And I ONLY accept matches from wired connections so this is quite alarming.
 
The last patched borked the PC version's frame rate, even offline line. A lot of people are getting around 25 FPS average, even if their system exceeds the recommended system requirements. After a bit things improve, but there's still hiccups here and there, and when you fire the game up later, it seems to start all over again.

I haven't played Online, but I've heard its messed as well.
 

TwiztidOne

I don't know who that is...
I was consistently playing matches that were around 50-100 ping. now every match i get is 100+ ping with huge lag spikes causing it to shoot up into the 200's.

Also the matchmaking is super weird. If I decline someone(wifi players) I keep getting matched with them, i didn't have this problem before the patch
 

Gaxkang

Noob
I don't play Ranked matches, I just play Casual matches so I'm unable to see the ping. HOWEVER, I am noticing my matches is getting much lag since the update w/ that yellow/red triangle appearing on the bottom of my screen way more than usual. And I ONLY accept matches from wired connections so this is quite alarming.
You can see ping in kasual fights, you gotta enable it in the options menu.

But yeah, the online is hot garbage right now. I'd say it issues before, but it's just gotten even worse now.
 

JBeezYBabY

Mr. Righteous
You can see ping in kasual fights, you gotta enable it in the options menu.

But yeah, the online is hot garbage right now. I'd say it issues before, but it's just gotten even worse now.
REALLY!? The bloody hell! So gonna do that when i get home. Thank ya kindly :)
 

Arqwart

Lean, mean, and +14
The last patched borked the PC version's frame rate, even offline line. A lot of people are getting around 25 FPS average, even if their system exceeds the recommended system requirements. After a bit things improve, but there's still hiccups here and there, and when you fire the game up later, it seems to start all over again.

I haven't played Online, but I've heard its messed as well.
Came here to say this and to point out that some levels are nigh unplayable as they randomly cause massive FPS losses. The main culprit I've found is Kahn's Arena. Ever since the update, it runs at sub-30 FPS and even regularly drops to just straight up visually freezing.
 
I knew something was wrong, I thought it was because of my connection. RIght after the 1.05 went live I had trouble to play in the KOTHs hosted by @Vslayer while the online was quite good for an European playing in a NA KOTH in 1.04. Now it lags a lot and I get kicked like half of the time when it's my turn to play against the king.
 
Last edited:
anyone notify NRS? We can talk about it all we want but unless they see this thread...
It's not NRS that needs to be notified, but WB Support who then filters info to NetherRealm Studios, QLOC, and Shiver respectively.

I've been talking with a WB Support agent for a week now via email (since Patch 4 on the PC, the 05/24 patch). The info I've provided is being sent to a Senior Agent, which is good. I'm dealing specifically with the PC version of the game though, since that's what I have.

I strongly encourage everyone to submit proper Support tickets for their respective issues, and provide all the details that you can. For those on a PC, they'll likely ask you to do some routine troubleshooting, so do that even though it won't resolve the issues so you can move along up the chain.

Also remember not to vent your anger on the basic support guys. They're not the ones who broke the game and they are going to be trying to help you.

To contact WB Support, you can follow the details in this Steam Post. While this is on the Steam site, it should apply to all versions of the game, not just the PC.
 

Eldriken

You are marked for termination.
Forum General
I don't play Ranked matches, I just play Casual matches so I'm unable to see the ping. HOWEVER, I am noticing my matches is getting much lag since the update w/ that yellow/red triangle appearing on the bottom of my screen way more than usual. And I ONLY accept matches from wired connections so this is quite alarming.
Kasual matches show the latency, I thought? The setting to display it at all should affect all modes. :confused:
 

Eldriken

You are marked for termination.
Forum General
I was consistently playing matches that were around 50-100 ping. now every match i get is 100+ ping with huge lag spikes causing it to shoot up into the 200's.

Also the matchmaking is super weird. If I decline someone(wifi players) I keep getting matched with them, i didn't have this problem before the patch
Same! I'll get matched up with the same person 4-5 times in a row as if we're the only people online.
 

Eldriken

You are marked for termination.
Forum General
I only see the bars at the bottom, but it does not show the number. Before the patch, I even faced a 2 bar wired connection and the game was perfectly fine. NOW? Shit....i stay far away from those connections.
Ohhh! You have to enable the setting that displays the actual latency numbers. It's in the same place as enabling it showing the quality.
 

JBeezYBabY

Mr. Righteous
Same! I'll get matched up with the same person 4-5 times in a row as if we're the only people online.
I was consistently playing matches that were around 50-100 ping. now every match i get is 100+ ping with huge lag spikes causing it to shoot up into the 200's.

Also the matchmaking is super weird. If I decline someone(wifi players) I keep getting matched with them, i didn't have this problem before the patch
YOOOO! ME TOO! Ok, this patched really fucked up online for many of us.